# Symfony has an Authentication Bypass via RememberMe

Advisory record · `GHSA-cg23-qf8f-62rr`

- **Identifiers:** `GHSA-cg23-qf8f-62rr` · `CVE-2024-51996` · `PKSA-rqvm-b18n-vg69` · `PKSA-yvfh-tnnw-3w9h`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html) · [CWE-289](https://cwe.mitre.org/data/definitions/289.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-289](https://agentprime.io/advisories/tag/cwe-289.md)
- **Published:** 13 Nov 2024
- **Updated:** 15 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Nov 2024, 18:29 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `symfony/security-http` (Packagist): affected `>=5.3.0, <5.4.47 || >=6.0.0-BETA1, <6.4.15 || >=7.0.0-BETA1, <7.1.8`; fixed in `5.4.47`, `6.4.15`, `7.1.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Symfony's symfony/security-http package is vulnerable in versions from 5.3.0 to before 5.4.47, from 6.0.0-BETA1 to before 6.4.15, and from 7.0.0-BETA1 to before 7.1.8. When a persisted remember-me cookie is consumed, the username stored in the database is not checked against the cookie's owner, which allows authentication bypass. Upgrade to 5.4.47, 6.4.15, 7.1.8 or later.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0062, the 49th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:29 UTC: First seen by agentprime
- 31 Oct 2026, 14:29 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-cg23-qf8f-62rr)

## Sources

- [GitHub Advisory Database: GHSA-cg23-qf8f-62rr](https://github.com/advisories/GHSA-cg23-qf8f-62rr)
- [OSV: GHSA-cg23-qf8f-62rr](https://osv.dev/vulnerability/GHSA-cg23-qf8f-62rr)
- <https://github.com/symfony/symfony/security/advisories/GHSA-cg23-qf8f-62rr>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-51996>
- <https://github.com/symfony/symfony/commit/81354d392c5f0b7a52bcbd729d6f82501e94135a>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-http/CVE-2024-51996.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2024-51996.yaml>
- <https://github.com/symfony/symfony>
- <https://symfony.com/cve-2024-51996>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cg23-qf8f-62rr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cg23-qf8f-62rr/>. Everything for agents: <https://agentprime.io/llms.txt>.
