# virtualenv activate.fish runs commands from a path or prompt with a backslash before a quote

Advisory record · `GHSA-c947-3pg5-gm8q`

- **Identifiers:** `GHSA-c947-3pg5-gm8q` · `BIT-virtualenv-2026-113732` · `CVE-2026-113732`
- **State:** Confirmed
- **Severity:** CVSS 7.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-78](https://cwe.mitre.org/data/definitions/78.html) · [CWE-116](https://cwe.mitre.org/data/definitions/116.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md) · [CWE-116](https://agentprime.io/advisories/tag/cwe-116.md)
- **Published:** 21 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Oct 2026, 16:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `virtualenv` (PyPI): affected `<21.14.2`; fixed in `21.14.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Virtualenv versions before 21.14.2 generate an activate.fish script that can run shell commands embedded in the environment path or prompt value, because a backslash before a quote is misread by fish. An attacker needs to control the environment path or prompt, for example through a CI job or a directory in a cloned repository, and the victim must source the generated activate.fish. Upgrade to virtualenv 21.14.2, which escapes these values correctly.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.8 High, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 14th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-c947-3pg5-gm8q)

## Sources

- [GitHub Advisory Database: GHSA-c947-3pg5-gm8q](https://github.com/advisories/GHSA-c947-3pg5-gm8q)
- [OSV: GHSA-c947-3pg5-gm8q](https://osv.dev/vulnerability/GHSA-c947-3pg5-gm8q)
- <https://github.com/pypa/virtualenv/security/advisories/GHSA-c947-3pg5-gm8q>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-113732>
- <https://github.com/pypa/virtualenv/commit/3bddeaf8d02c3ee7f576503efb082f8f494cfcab>
- <https://github.com/pypa/virtualenv>
- <https://github.com/pypa/virtualenv/releases/tag/21.14.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c947-3pg5-gm8q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c947-3pg5-gm8q/>. Everything for agents: <https://agentprime.io/llms.txt>.
