# json-jwt allows bypass of identity checks via a sign/encryption confusion attack

Advisory record · `GHSA-c8v6-786g-vjx6`

- **Identifiers:** `GHSA-c8v6-786g-vjx6` · `CVE-2023-51774`
- **State:** Confirmed
- **Severity:** CVSS 8.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-284](https://cwe.mitre.org/data/definitions/284.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 29 Feb 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Feb 2024, 03:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `json-jwt` (RubyGems): affected `>=1.16.0, <1.16.6 || <1.15.3.1`; fixed in `1.16.6`, `1.15.3.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.4 High, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from ADP (CISA-ADP)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0023, the 14th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-c8v6-786g-vjx6)

## Sources

- [GitHub Advisory Database: GHSA-c8v6-786g-vjx6](https://github.com/advisories/GHSA-c8v6-786g-vjx6)
- [OSV: GHSA-c8v6-786g-vjx6](https://osv.dev/vulnerability/GHSA-c8v6-786g-vjx6)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-51774>
- <https://github.com/nov/json-jwt/issues/120>
- <https://github.com/nov/json-jwt/issues/121>
- <https://github.com/nov/json-jwt/commit/593ea8bcaf2629048bad8c036191f2da0a2e713c>
- <https://github.com/nov/json-jwt/commit/9c4d842a9465bd7960570ca326c3de79b4abc9d0>
- <https://github.com/P3ngu1nW/CVE_Request/blob/main/novjson-jwt.md>
- <https://github.com/nov/json-jwt>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/json-jwt/CVE-2023-51774.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c8v6-786g-vjx6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c8v6-786g-vjx6/>. Everything for agents: <https://agentprime.io/llms.txt>.
