# Formwork improperly validates input of User role preventing site and panel availability

Advisory record · `GHSA-c85w-x26q-ch87`

- **Identifiers:** `GHSA-c85w-x26q-ch87` · `PKSA-f12j-yzp4-332f`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html) · [CWE-1285](https://cwe.mitre.org/data/definitions/1285.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md) · [CWE-1285](https://agentprime.io/advisories/tag/cwe-1285.md)
- **Published:** 1 Mar 2025
- **Updated:** 22 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Mar 2025, 00:11 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `getformwork/formwork` (Packagist): affected `>=2.0.0-beta.1, <2.0.0-beta.4`; fixed in `2.0.0-beta.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Formwork (Packagist package getformwork/formwork) versions 2.0.0-beta.1 up to but not including 2.0.0-beta.4 are affected. An attacker with administrator access, or with a privileged account, can submit an invalid user role value that makes the user's data unloadable, causing a 500 error that takes down the entire site and administration panel until the account file is restored by hand. Upgrade to 2.0.0-beta.4, which adds validation for select fields.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:26 UTC: First seen by agentprime
- 31 Oct 2026, 14:26 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-c85w-x26q-ch87)

## Sources

- [GitHub Advisory Database: GHSA-c85w-x26q-ch87](https://github.com/advisories/GHSA-c85w-x26q-ch87)
- [OSV: GHSA-c85w-x26q-ch87](https://osv.dev/vulnerability/GHSA-c85w-x26q-ch87)
- <https://github.com/getformwork/formwork/security/advisories/GHSA-c85w-x26q-ch87>
- <https://github.com/getformwork/formwork/commit/d9f0c1feb3b9855d5bdc8bb189c0aaab2792e7ca>
- <https://github.com/getformwork/formwork>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c85w-x26q-ch87>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c85w-x26q-ch87/>. Everything for agents: <https://agentprime.io/llms.txt>.
