# opennextjs-cloudflare has SSRF vulnerability via /cdn-cgi/ path normalization bypass

Advisory record · `GHSA-c7mq-gh6q-6q7c`

- **Identifiers:** `GHSA-c7mq-gh6q-6q7c` · `CVE-2025-6087` · `CVE-2026-3125` · `GHSA-rvpw-p7vw-wj3m`
- **State:** Confirmed
- **Severity:** CVSS 7.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-706](https://cwe.mitre.org/data/definitions/706.html) · [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md) · [CWE-706](https://agentprime.io/advisories/tag/cwe-706.md)
- **Published:** 5 Mar 2026
- **Updated:** 16 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Mar 2026, 00:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@opennextjs/cloudflare` (npm): affected `<1.17.1`; fixed in `1.17.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.8 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:H/SI:L/SA:N`, from CNA (cloudflare)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0097, the 61st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 5 Mar 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-c7mq-gh6q-6q7c](https://github.com/advisories/GHSA-c7mq-gh6q-6q7c)
- [OSV: GHSA-c7mq-gh6q-6q7c](https://osv.dev/vulnerability/GHSA-c7mq-gh6q-6q7c)
- <https://github.com/opennextjs/opennextjs-cloudflare/security/advisories/GHSA-c7mq-gh6q-6q7c>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-3125>
- <https://github.com/opennextjs/opennextjs-cloudflare/pull/1147>
- <https://github.com/opennextjs/opennextjs-cloudflare/commit/f5bd138fd3c77e02f2aa4b9c76d55681e59e98b4>
- <https://github.com/advisories/GHSA-rvpw-p7vw-wj3m>
- <https://github.com/opennextjs/opennextjs-cloudflare>
- <https://www.cve.org/cverecord?id=CVE-2025-6087>
- <https://www.npmjs.com/package/@opennextjs/cloudflare/v/1.17.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c7mq-gh6q-6q7c>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c7mq-gh6q-6q7c/>. Everything for agents: <https://agentprime.io/llms.txt>.
