# Possible Denial of Service Vulnerability in Rack's header parsing

Advisory record · `GHSA-c6qg-cjj8-47qp`

- **Identifiers:** `GHSA-c6qg-cjj8-47qp` · `CVE-2023-27539`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Published:** 15 Mar 2023
- **Updated:** 9 Jan 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Mar 2023, 21:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `rack` (RubyGems): affected `>=2.0.0, <2.2.6.4 || >=3.0.0, <3.0.6.1`; fixed in `2.2.6.4`, `3.0.6.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`, from ADP (CISA-ADP)

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 64th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 15 Mar 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-c6qg-cjj8-47qp](https://github.com/advisories/GHSA-c6qg-cjj8-47qp)
- [OSV: GHSA-c6qg-cjj8-47qp](https://osv.dev/vulnerability/GHSA-c6qg-cjj8-47qp)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-27539>
- <https://github.com/rack/rack/commit/231ef369ad0b542575fb36c74fcfcfabcf6c530c>
- <https://github.com/rack/rack/commit/ee7919ea04303717858be1c3f16b406adc6d8cff>
- <https://discuss.rubyonrails.org/t/cve-2023-27539-possible-denial-of-service-vulnerability-in-racks-header-parsing/82466>
- <https://github.com/rack/rack>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2023-27539.yml>
- <https://lists.debian.org/debian-lts-announce/2023/04/msg00017.html>
- <https://security.netapp.com/advisory/ntap-20231208-0016>
- <https://www.debian.org/security/2023/dsa-5530>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c6qg-cjj8-47qp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c6qg-cjj8-47qp/>. Everything for agents: <https://agentprime.io/llms.txt>.
