# Vite Plugin React has a Source Code Exposure Vulnerability in React Server Components

Advisory record · `GHSA-c6m7-q6pr-c64r`

- **Identifiers:** `GHSA-c6m7-q6pr-c64r`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-497](https://cwe.mitre.org/data/definitions/497.html) · [CWE-502](https://cwe.mitre.org/data/definitions/502.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 12 Dec 2025
- **Updated:** 12 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Dec 2025, 16:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@vitejs/plugin-rsc` (npm): affected `<0.5.7`; fixed in `0.5.7`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 Dec 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-c6m7-q6pr-c64r](https://github.com/advisories/GHSA-c6m7-q6pr-c64r)
- [OSV: GHSA-c6m7-q6pr-c64r](https://osv.dev/vulnerability/GHSA-c6m7-q6pr-c64r)
- <https://github.com/facebook/react/security/advisories/GHSA-925w-6v3x-g4j4>
- <https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-c6m7-q6pr-c64r>
- <https://github.com/vitejs/vite-plugin-react>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c6m7-q6pr-c64r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c6m7-q6pr-c64r/>. Everything for agents: <https://agentprime.io/llms.txt>.
