# laravel-auth0 SDK Deserialization of Untrusted Data vulnerability

Advisory record · `GHSA-c42h-56wx-h85q`

- **Identifiers:** `GHSA-c42h-56wx-h85q` · `PKSA-73kk-h2rk-mk8g`
- **State:** Confirmed
- **Severity:** CVSS 4.0, no score published
- **Critical:** No
- **Weakness (CWE):** [CWE-502](https://cwe.mitre.org/data/definitions/502.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 6 Jun 2025
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Jun 2025, 15:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `auth0/login` (Packagist): affected `>=7.0.0-BETA1, <7.2.2`; fixed in `7.2.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The auth0/login package (laravel-auth0 SDK) versions from 7.0.0-BETA1 before 7.2.2 are affected by insecure deserialization of cookie data. An unauthenticated attacker can send a specially crafted cookie containing malicious serialized data, and the source does not state the resulting impact. Upgrade auth0/login to version 7.2.2 or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- Score not published, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:26 UTC: First seen by agentprime
- 31 Oct 2026, 14:26 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-c42h-56wx-h85q)

## Sources

- [GitHub Advisory Database: GHSA-c42h-56wx-h85q](https://github.com/advisories/GHSA-c42h-56wx-h85q)
- [OSV: GHSA-c42h-56wx-h85q](https://osv.dev/vulnerability/GHSA-c42h-56wx-h85q)
- <https://github.com/auth0/auth0-PHP/security/advisories/GHSA-v9m8-9xxp-q492>
- <https://github.com/auth0/laravel-auth0/security/advisories/GHSA-c42h-56wx-h85q>
- <https://github.com/auth0/symfony/security/advisories/GHSA-98j6-67v3-mw34>
- <https://github.com/auth0/wordpress/security/advisories/GHSA-862m-5253-832r>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-48951>
- <https://github.com/auth0/laravel-auth0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c42h-56wx-h85q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c42h-56wx-h85q/>. Everything for agents: <https://agentprime.io/llms.txt>.
