# Netty has a Vulnerable Default Configuration Which Leads to Denial of Service via Unbounded HTTP/3 Header Size

Advisory record · `GHSA-c2rx-5r8w-8xr2`

- **Identifiers:** `GHSA-c2rx-5r8w-8xr2` · `CVE-2026-44892`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-1188](https://cwe.mitre.org/data/definitions/1188.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-1188](https://agentprime.io/advisories/tag/cwe-1188.md)
- **Published:** 8 Jun 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Jun 2026, 19:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-codec-http3` (Maven): affected `>=4.2.0.Final, <4.2.15.Final`; fixed in `4.2.15.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Netty's io.netty:netty-codec-http3 package, versions 4.2.0.Final through before 4.2.15.Final, uses an unlimited default maximum header size for HTTP/3 connections when the peer does not set one. A malicious client or server can send a large number of headers over a connection, exhausting memory and causing an OutOfMemoryError that crashes the application. Upgrade to 4.2.15.Final or later; the source does not list a configuration workaround.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0028, the 20th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-c2rx-5r8w-8xr2)

## Sources

- [GitHub Advisory Database: GHSA-c2rx-5r8w-8xr2](https://github.com/advisories/GHSA-c2rx-5r8w-8xr2)
- [OSV: GHSA-c2rx-5r8w-8xr2](https://osv.dev/vulnerability/GHSA-c2rx-5r8w-8xr2)
- <https://github.com/netty/netty/security/advisories/GHSA-c2rx-5r8w-8xr2>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-44892>
- <https://github.com/netty/netty>
- <https://github.com/netty/netty/releases/tag/netty-4.2.15.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c2rx-5r8w-8xr2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c2rx-5r8w-8xr2/>. Everything for agents: <https://agentprime.io/llms.txt>.
