# Puma HTTP Request/Response Smuggling vulnerability

Advisory record · `GHSA-c2f4-cvqm-65w2`

- **Identifiers:** `GHSA-c2f4-cvqm-65w2` · `CVE-2024-21647`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 8 Jan 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Jan 2024, 15:56 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `puma` (RubyGems): affected `>=6.0.0, <6.4.2 || <5.6.8`; fixed in `6.4.2`, `5.6.8`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0096, the 61st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-c2f4-cvqm-65w2)

## Sources

- [GitHub Advisory Database: GHSA-c2f4-cvqm-65w2](https://github.com/advisories/GHSA-c2f4-cvqm-65w2)
- [OSV: GHSA-c2f4-cvqm-65w2](https://osv.dev/vulnerability/GHSA-c2f4-cvqm-65w2)
- <https://github.com/puma/puma/security/advisories/GHSA-c2f4-cvqm-65w2>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-21647>
- <https://github.com/puma/puma/commit/5fc43d73b6ff193325e657a24ed76dec79133e93>
- <https://github.com/puma/puma/commit/60d5ee3734adc8cee85c3f0561af392448fe19b7>
- <https://github.com/puma/puma/commit/bbb880ffb6debbfdea535b4b3eb2204d49ae151d>
- <https://github.com/puma/puma>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2024-21647.yml>
- <https://lists.debian.org/debian-lts-announce/2024/11/msg00004.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c2f4-cvqm-65w2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c2f4-cvqm-65w2/>. Everything for agents: <https://agentprime.io/llms.txt>.
