# Vite dev server option \`server.fs.deny\` can be bypassed when hosted on case-insensitive filesystem

Advisory record · `GHSA-c24v-8rfc-w8vw`

- **Identifiers:** `GHSA-c24v-8rfc-w8vw` · `CVE-2024-23331`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-178](https://cwe.mitre.org/data/definitions/178.html) · [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-284](https://cwe.mitre.org/data/definitions/284.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-178](https://agentprime.io/advisories/tag/cwe-178.md)
- **Published:** 19 Jan 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Jan 2024, 21:58 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vite` (npm): affected `>=2.7.0, <2.9.17 || >=3.0.0, <3.2.8 || >=4.0.0, <4.5.2 || >=5.0.0, <5.0.12`; fixed in `2.9.17`, `3.2.8`, `4.5.2`, `5.0.12`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0078, the 56th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 19 Jan 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-c24v-8rfc-w8vw](https://github.com/advisories/GHSA-c24v-8rfc-w8vw)
- [OSV: GHSA-c24v-8rfc-w8vw](https://osv.dev/vulnerability/GHSA-c24v-8rfc-w8vw)
- <https://github.com/vitejs/vite/security/advisories/GHSA-c24v-8rfc-w8vw>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-34092>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-23331>
- <https://github.com/vitejs/vite/commit/0cd769c279724cf27934b1270fbdd45d68217691>
- <https://github.com/vitejs/vite/commit/91641c4da0a011d4c5352e88fc68389d4e1289a5>
- <https://github.com/vitejs/vite/commit/a26c87d20f9af306b5ce3ff1648be7fa5146c278>
- <https://github.com/vitejs/vite/commit/eeec23bbc9d476c54a3a6d36e78455867185a7cb>
- <https://github.com/vitejs/vite>
- <https://vitejs.dev/config/server-options.html#server-fs-deny>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-c24v-8rfc-w8vw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-c24v-8rfc-w8vw/>. Everything for agents: <https://agentprime.io/llms.txt>.
