# WP Crontrol vulnerable to possible RCE when combined with a pre-condition

Advisory record · `GHSA-9xvf-cjvf-ff5q`

- **Identifiers:** `GHSA-9xvf-cjvf-ff5q` · `CVE-2024-28850` · `PKSA-rnp9-g2v1-bz2h`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-494](https://cwe.mitre.org/data/definitions/494.html)
- **Tags:** [CWE-494](https://agentprime.io/advisories/tag/cwe-494.md)
- **Published:** 25 Mar 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Mar 2024, 19:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `johnbillion/wp-crontrol` (Packagist): affected `<1.16.2`; fixed in `1.16.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> WP Crontrol, the johnbillion/wp-crontrol package on Packagist, is affected in versions before 1.16.2. The feature that stores and runs PHP code in WP-Cron events has no known vulnerability on its own, but it could allow remote code execution if an attacker chains it with a separate flaw, such as a SQL injection or the ability to alter the wp_options table. Upgrade to version 1.16.2, which adds an HMAC integrity check on stored PHP cron events; events saved before the update stop running until an administrator re-saves them.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0017, the 5th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:03 UTC: First seen by agentprime
- 31 Oct 2026, 14:03 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9xvf-cjvf-ff5q)

## Sources

- [GitHub Advisory Database: GHSA-9xvf-cjvf-ff5q](https://github.com/advisories/GHSA-9xvf-cjvf-ff5q)
- [OSV: GHSA-9xvf-cjvf-ff5q](https://osv.dev/vulnerability/GHSA-9xvf-cjvf-ff5q)
- <https://github.com/johnbillion/wp-crontrol/security/advisories/GHSA-9xvf-cjvf-ff5q>
- <https://github.com/johnbillion/wp-crontrol/commit/6d1fadcf6dfdd54e55feef27f916b0cfcd602405>
- <https://github.com/johnbillion/wp-crontrol>
- <https://github.com/johnbillion/wp-crontrol/releases/tag/1.16.2>
- <https://snicco.io/vulnerability-disclosure>
- <https://wp-crontrol.com/docs/php-cron-events>
- <https://wp-crontrol.com/help/check-php-cron-events>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9xvf-cjvf-ff5q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9xvf-cjvf-ff5q/>. Everything for agents: <https://agentprime.io/llms.txt>.
