# Requests \`Session\` object does not verify requests after making first request with verify=False

Advisory record · `GHSA-9wx4-h78v-vm56`

- **Identifiers:** `GHSA-9wx4-h78v-vm56` · `CVE-2024-35195` · `PYSEC-2026-1873`
- **State:** Confirmed
- **Severity:** CVSS 5.6 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-670](https://cwe.mitre.org/data/definitions/670.html)
- **Tags:** [CWE-670](https://agentprime.io/advisories/tag/cwe-670.md)
- **Published:** 20 May 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 May 2024, 20:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `requests` (PyPI): affected `<2.32.0`; fixed in `2.32.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The requests package, versions before 2.32.0, can keep TLS certificate verification disabled for later requests in a Session. If the first request to an origin uses verify=False, pooled connections may skip verification even when verify=True is set later. An attacker positioned on the network path could then intercept or alter traffic. Upgrade requests to 2.32.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.6 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9wx4-h78v-vm56)

## Sources

- [GitHub Advisory Database: GHSA-9wx4-h78v-vm56](https://github.com/advisories/GHSA-9wx4-h78v-vm56)
- [OSV: GHSA-9wx4-h78v-vm56](https://osv.dev/vulnerability/GHSA-9wx4-h78v-vm56)
- <https://github.com/psf/requests/security/advisories/GHSA-9wx4-h78v-vm56>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-35195>
- <https://github.com/psf/requests/pull/6655>
- <https://github.com/psf/requests/commit/a58d7f2ffb4d00b46dca2d70a3932a0b37e22fac>
- <https://github.com/psf/requests>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IYLSNK5TL46Q6XPRVMHVWS63MVJQOK4Q>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N7WP6EYDSUOCOJYHDK5NX43PYZ4SNHGZ>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9wx4-h78v-vm56>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9wx4-h78v-vm56/>. Everything for agents: <https://agentprime.io/llms.txt>.
