# phpMyFAQ duplicate email registration allows multiple accounts with the same email

Advisory record · `GHSA-9wj2-4hcm-r74j`

- **Identifiers:** `GHSA-9wj2-4hcm-r74j` · `CVE-2025-59943` · `PKSA-pzch-4td8-nkvb`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-284](https://cwe.mitre.org/data/definitions/284.html) · [CWE-286](https://cwe.mitre.org/data/definitions/286.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-286](https://agentprime.io/advisories/tag/cwe-286.md)
- **Published:** 3 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Oct 2025, 14:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `thorsten/phpmyfaq` (Packagist): affected `>=4.0.7, <4.0.13`; fixed in `4.0.13`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Affected versions of the Packagist package thorsten/phpmyfaq from 4.0.7 before 4.0.13 do not enforce email uniqueness during user registration, so several accounts can share one email address. The source says an attacker can register multiple accounts with the same email, and that this may enable account takeover or privilege escalation where email drives password resets or admin flows, though the source gives few details on how these outcomes occur. Upgrade to version 4.0.13, which is the listed fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0042, the 36th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:03 UTC: First seen by agentprime
- 31 Oct 2026, 14:03 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9wj2-4hcm-r74j)

## Sources

- [GitHub Advisory Database: GHSA-9wj2-4hcm-r74j](https://github.com/advisories/GHSA-9wj2-4hcm-r74j)
- [OSV: GHSA-9wj2-4hcm-r74j](https://osv.dev/vulnerability/GHSA-9wj2-4hcm-r74j)
- <https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-9wj2-4hcm-r74j>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-59943>
- <https://github.com/thorsten/phpMyFAQ/commit/44cd20f86eb041f39d1c30a9beefad1cc61dc0ec>
- <https://github.com/thorsten/phpMyFAQ>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9wj2-4hcm-r74j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9wj2-4hcm-r74j/>. Everything for agents: <https://agentprime.io/llms.txt>.
