# Moodle's mod_data edit/delete pages pass CSRF token in GET parameter

Advisory record · `GHSA-9vc3-vm42-fjhm`

- **Identifiers:** `GHSA-9vc3-vm42-fjhm` · `BIT-moodle-2025-3637` · `CVE-2025-3637` · `PKSA-fvfh-pt1s-3tmx`
- **State:** Confirmed
- **Severity:** CVSS 3.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-598](https://cwe.mitre.org/data/definitions/598.html)
- **Tags:** [CWE-598](https://agentprime.io/advisories/tag/cwe-598.md)
- **Published:** 25 Apr 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Apr 2025, 15:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `moodle/moodle` (Packagist): affected `<4.3.12 || >=4.3.0-beta, <4.3.12 || >=4.4.0-beta, <4.4.8 || >=4.5.0-beta, <4.5.4`; fixed in `4.3.12`, `4.4.8`, `4.5.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Moodle (moodle/moodle on Packagist) is affected in the mod_data module's edit and delete pages, which expose the CSRF token in a GET parameter, in versions before 4.3.12, from 4.4.0-beta before 4.4.8, and from 4.5.0-beta before 4.5.4. The source says an attacker could see this token through the site's URL, which weakens protection against cross-site request forgery, but it gives few details on the conditions required. Upgrade to 4.3.12, 4.4.8, or 4.5.4, which are listed as fixed versions.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.1 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`, from CNA (fedora)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:03 UTC: First seen by agentprime
- 31 Oct 2026, 14:03 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9vc3-vm42-fjhm)

## Sources

- [GitHub Advisory Database: GHSA-9vc3-vm42-fjhm](https://github.com/advisories/GHSA-9vc3-vm42-fjhm)
- [OSV: GHSA-9vc3-vm42-fjhm](https://osv.dev/vulnerability/GHSA-9vc3-vm42-fjhm)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-3637>
- <https://github.com/moodle/moodle/commit/052007b7324ef24aebe36a876ffa4fa97fac4f81>
- <https://access.redhat.com/security/cve/CVE-2025-3637>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2359727>
- <https://github.com/moodle/moodle>
- <https://moodle.org/mod/forum/discuss.php?d=467599>
- <http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-65356>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9vc3-vm42-fjhm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9vc3-vm42-fjhm/>. Everything for agents: <https://agentprime.io/llms.txt>.
