# Panics on Malformed Untrusted Input

Advisory record · `GHSA-9rmp-2568-59rv`

- **Identifiers:** `GHSA-9rmp-2568-59rv` · `CVE-2024-53856` · `RUSTSEC-2024-0447`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-130](https://cwe.mitre.org/data/definitions/130.html) · [CWE-148](https://cwe.mitre.org/data/definitions/148.html) · [CWE-617](https://cwe.mitre.org/data/definitions/617.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-130](https://agentprime.io/advisories/tag/cwe-130.md) · [CWE-148](https://agentprime.io/advisories/tag/cwe-148.md)
- **Published:** 5 Dec 2024
- **Updated:** 12 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Dec 2024, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pgp` (crates.io): affected `>=0.0.0-0, <0.14.1`; fixed in `0.14.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The pgp crate for Rust (crates.io) is affected in versions before 0.14.1. A remote attacker can supply crafted, malformed OpenPGP data, such as messages, keys, or cleartext signatures, to trigger a panic that halts the program, causing denial of service. Upgrade to pgp 0.14.1 or later; no workaround is listed.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0047, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2024-0447)

## Sources

- [GitHub Advisory Database: GHSA-9rmp-2568-59rv](https://github.com/advisories/GHSA-9rmp-2568-59rv)
- [OSV: GHSA-9rmp-2568-59rv](https://osv.dev/vulnerability/GHSA-9rmp-2568-59rv)
- <https://crates.io/crates/pgp>
- <https://rustsec.org/advisories/RUSTSEC-2024-0447.html>
- <https://github.com/rpgp/rpgp/commit/91b9f517f3bc38e7b14518a156bff81ee69301fc>
- <https://github.com/radicallyopensecurity/ros-website/blob/8169b16fc138a0b0dde14dd0e222d1279701b4d3/ros-public-reports/ROS%20-%20NLNet%20-%20rPGP%20-%202024.pdf>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9rmp-2568-59rv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9rmp-2568-59rv/>. Everything for agents: <https://agentprime.io/llms.txt>.
