# Phusion Passenger Denial of Service

Advisory record · `GHSA-9qj7-jvg4-qr2x`

- **Identifiers:** `GHSA-9qj7-jvg4-qr2x` · `CVE-2013-2119`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-377](https://cwe.mitre.org/data/definitions/377.html)
- **Tags:** [CWE-377](https://agentprime.io/advisories/tag/cwe-377.md)
- **Published:** 24 Oct 2017
- **Updated:** 8 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Oct 2017, 18:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `passenger` (RubyGems): affected `<3.0.21 || >=4.0.1, <4.0.5`; fixed in `3.0.21`, `4.0.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.0040, the 34th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Oct 2017. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-9qj7-jvg4-qr2x](https://github.com/advisories/GHSA-9qj7-jvg4-qr2x)
- [OSV: GHSA-9qj7-jvg4-qr2x](https://osv.dev/vulnerability/GHSA-9qj7-jvg4-qr2x)
- <https://nvd.nist.gov/vuln/detail/CVE-2013-2119>
- <https://access.redhat.com/errata/RHSA-2013:1136>
- <https://access.redhat.com/security/cve/CVE-2013-2119>
- <https://bugzilla.redhat.com/show_bug.cgi?id=892813>
- <https://github.com/advisories/GHSA-9qj7-jvg4-qr2x>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/passenger/CVE-2013-2119.yml>
- <http://blog.phusion.nl/2013/05/29/phusion-passenger-3-0-21-released>
- <http://blog.phusion.nl/2013/05/29/phusion-passenger-4-0-5-released>
- <http://rhn.redhat.com/errata/RHSA-2013-1136.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9qj7-jvg4-qr2x>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9qj7-jvg4-qr2x/>. Everything for agents: <https://agentprime.io/llms.txt>.
