# Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints

Advisory record · `GHSA-9qf2-26p9-2q2q`

- **Identifiers:** `GHSA-9qf2-26p9-2q2q` · `CVE-2026-47892`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 27 Aug 2026
- **Updated:** 7 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Aug 2026, 06:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.springframework:spring-webflux` (Maven): affected `>=5.2.5.RELEASE, <=5.2.25.RELEASE || >=5.3.0, <=5.3.49 || >=6.0.0, <=6.0.30 || >=6.1.0, <=6.1.28 || >=6.2.0, <=6.2.19 || >=7.0.0, <7.0.9`; fixed in `7.0.9`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Spring Framework's spring-webflux package is affected in versions 5.2.5.RELEASE through 5.2.25.RELEASE, 5.3.0 through 5.3.49, 6.0.0 through 6.0.30, 6.1.0 through 6.1.28, 6.2.0 through 6.2.19, and 7.0.0 through 7.0.8. A WebFlux application using functional endpoints and deployed with DispatcherServlet may allow a header predicate bypass in a pre-flight request, and the source gives few further details on the attack conditions. Upgrade spring-webflux to 7.0.9 or a later fixed version.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 45th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9qf2-26p9-2q2q)

## Sources

- [GitHub Advisory Database: GHSA-9qf2-26p9-2q2q](https://github.com/advisories/GHSA-9qf2-26p9-2q2q)
- [OSV: GHSA-9qf2-26p9-2q2q](https://osv.dev/vulnerability/GHSA-9qf2-26p9-2q2q)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-47892>
- <https://github.com/spring-projects/spring-framework>
- <https://spring.io/security/cve-2026-47892>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9qf2-26p9-2q2q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9qf2-26p9-2q2q/>. Everything for agents: <https://agentprime.io/llms.txt>.
