# fastify vulnerable to header validation bypass via incomplete schema case normalization

Advisory record · `GHSA-9q9j-q6p8-xq58`

- **Identifiers:** `GHSA-9q9j-q6p8-xq58` · `CVE-2026-84428`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-178](https://cwe.mitre.org/data/definitions/178.html)
- **Tags:** [CWE-178](https://agentprime.io/advisories/tag/cwe-178.md)
- **Published:** 30 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Sept 2026, 23:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fastify` (npm): affected `<5.12.2`; fixed in `5.12.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-9q9j-q6p8-xq58 affects the npm package fastify before 5.12.2. Header schemas that use JSON Schema \`dependencies\` with mixed-case header names are not normalized correctly, so a dependency between headers can be silently skipped. An unauthenticated remote client can send the header that activates a privileged path while omitting the dependent header, bypassing that schema-enforced control. Upgrade to fastify 5.12.2 or later, which also appears in 6.0.0; if upgrading is not possible, use lowercase header-schema names or enforce the check in an onRequest or preValidation hook.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9q9j-q6p8-xq58)

## Sources

- [GitHub Advisory Database: GHSA-9q9j-q6p8-xq58](https://github.com/advisories/GHSA-9q9j-q6p8-xq58)
- [OSV: GHSA-9q9j-q6p8-xq58](https://osv.dev/vulnerability/GHSA-9q9j-q6p8-xq58)
- <https://github.com/fastify/fastify/security/advisories/GHSA-9q9j-q6p8-xq58>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-84428>
- <https://github.com/fastify/fastify/commit/179619c8e99d54924309b9933402151ef9af37e0>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/fastify/fastify>
- <https://github.com/fastify/fastify/releases/tag/v5.12.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9q9j-q6p8-xq58>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9q9j-q6p8-xq58/>. Everything for agents: <https://agentprime.io/llms.txt>.
