# Duplicate Advisory: OpenClaw session transcript files were created without forced user-only permissions

Advisory record · `GHSA-9q8j-chc7-wpgp` · Withdrawn

- **Identifiers:** `GHSA-9q8j-chc7-wpgp`
- **State:** Withdrawn
- **Severity:** CVSS 8.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-378](https://cwe.mitre.org/data/definitions/378.html)
- **Tags:** [CWE-378](https://agentprime.io/advisories/tag/cwe-378.md)
- **Published:** 29 Mar 2026
- **Updated:** 6 Apr 2026
- **Reviewed by a person:** No

**Withdrawn.** The GitHub Advisory Database withdrew this advisory on 6 Apr 2026. The record stays here, marked withdrawn.

Published by the GitHub Advisory Database at 29 Mar 2026, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `openclaw` (npm): affected `<2026.2.17`; fixed in `2026.2.17`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.4 High, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 29 Mar 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-9q8j-chc7-wpgp](https://github.com/advisories/GHSA-9q8j-chc7-wpgp)
- [OSV: GHSA-9q8j-chc7-wpgp](https://osv.dev/vulnerability/GHSA-9q8j-chc7-wpgp)
- <https://github.com/openclaw/openclaw/security/advisories/GHSA-vr7j-g7jv-h5mp>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33572>
- <https://github.com/openclaw/openclaw/commit/095d522099653367e1b76fa5bb09d4ddf7c8a57c>
- <https://www.vulncheck.com/advisories/openclaw-insufficient-file-permissions-in-session-transcript-files>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9q8j-chc7-wpgp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9q8j-chc7-wpgp/>. Everything for agents: <https://agentprime.io/llms.txt>.
