# openssl_encrypt versions before 1.4.0 contain a plugin sandbox bypass vulnerability where the PluginImportGuard blocks a different set of modules than the AST analyzer's DANGEROUS_MODULES set. Atta...

Advisory record · `GHSA-9pgj-v69p-q586`

- **Identifiers:** `GHSA-9pgj-v69p-q586` · `CVE-2026-74886` · `PYSEC-2026-3763`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-184](https://cwe.mitre.org/data/definitions/184.html)
- **Tags:** [CWE-184](https://agentprime.io/advisories/tag/cwe-184.md)
- **Published:** 17 Aug 2026
- **Updated:** 2 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Aug 2026, 11:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `openssl-encrypt` (PyPI): affected `<1.4.0`; fixed in `1.4.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> openssl-encrypt versions before 1.4.0 have a plugin sandbox bypass: the import guard blocks a different set of modules than the AST analyzer checks. An attacker who can supply a plugin can use string obfuscation or encoding to evade the AST analysis and import modules such as sys, shutil, multiprocessing, importlib, and pickle, allowing arbitrary code execution. Upgrade to openssl-encrypt 1.4.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0068, the 52nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:38 UTC: First seen by agentprime
- 31 Oct 2026, 14:38 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-3763)

## Sources

- [GitHub Advisory Database: GHSA-9pgj-v69p-q586](https://github.com/advisories/GHSA-9pgj-v69p-q586)
- [OSV: GHSA-9pgj-v69p-q586](https://osv.dev/vulnerability/GHSA-9pgj-v69p-q586)
- <https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-9pgj-v69p-q586>
- <https://www.vulncheck.com/advisories/openssl-encrypt-before-plugin-import-guard-bypass>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9pgj-v69p-q586>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9pgj-v69p-q586/>. Everything for agents: <https://agentprime.io/llms.txt>.
