# Phlex vulnerable to Cross-site Scripting (XSS) via maliciously formed HTML attribute names and values

Advisory record · `GHSA-9p57-h987-4vgx`

- **Identifiers:** `GHSA-9p57-h987-4vgx` · `CVE-2024-32970`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 1 May 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 May 2024, 16:37 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `phlex` (RubyGems): affected `<1.9.3 || >=1.10.0, <1.10.2`; fixed in `1.9.3`, `1.10.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0071, the 53rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9p57-h987-4vgx)

## Sources

- [GitHub Advisory Database: GHSA-9p57-h987-4vgx](https://github.com/advisories/GHSA-9p57-h987-4vgx)
- [OSV: GHSA-9p57-h987-4vgx](https://osv.dev/vulnerability/GHSA-9p57-h987-4vgx)
- <https://github.com/phlex-ruby/phlex/security/advisories/GHSA-9p57-h987-4vgx>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-32970>
- <https://github.com/phlex-ruby/phlex/commit/da8f94342a84cff9d78c98bcc3b3604ee2e577d2>
- <https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy>
- <https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline>
- <https://github.com/payloadbox/xss-payload-list>
- <https://github.com/phlex-ruby/phlex>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/phlex/CVE-2024-32970.yml>
- <https://rubygems.org/gems/phlex>
- <https://rubygems.org/gems/phlex/versions/1.10.2>
- <https://rubygems.org/gems/phlex/versions/1.9.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9p57-h987-4vgx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9p57-h987-4vgx/>. Everything for agents: <https://agentprime.io/llms.txt>.
