# erlang-jose vulnerable to denial of service via large p2c value

Advisory record · `GHSA-9mg4-v392-8j68`

- **Identifiers:** `GHSA-9mg4-v392-8j68` · `CVE-2023-50966`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 19 Mar 2024
- **Updated:** 10 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Mar 2024, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `jose` (Hex): affected `<1.11.7`; fixed in `1.11.7`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0089, the 59th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:25 UTC: First seen by agentprime
- 31 Oct 2026, 15:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9mg4-v392-8j68)

## Sources

- [GitHub Advisory Database: GHSA-9mg4-v392-8j68](https://github.com/advisories/GHSA-9mg4-v392-8j68)
- [OSV: GHSA-9mg4-v392-8j68](https://osv.dev/vulnerability/GHSA-9mg4-v392-8j68)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-50966>
- <https://github.com/potatosalad/erlang-jose/commit/718d213f07b08056737923f8063d5df56dcb66ae>
- <https://github.com/P3ngu1nW/CVE_Request/blob/main/erlang-jose.md>
- <https://github.com/potatosalad/erlang-jose>
- <https://hexdocs.pm/jose/JOSE.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9mg4-v392-8j68>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9mg4-v392-8j68/>. Everything for agents: <https://agentprime.io/llms.txt>.
