# pyasn1 has quadratic-time denial of service in constructed string and indefinite-length ANY decoding

Advisory record · `GHSA-9m75-vc3g-4x39`

- **Identifiers:** `GHSA-9m75-vc3g-4x39` · `CVE-2026-119195`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-407](https://cwe.mitre.org/data/definitions/407.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 30 Oct 2026
- **Updated:** 30 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Oct 2026, 23:03 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pyasn1` (PyPI): affected `<0.6.5`; fixed in `0.6.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> pyasn1 versions before 0.6.5 take roughly quadratic time to decode constructed OCTET STRING and character string values, and indefinite-length ANY values, that are split into many fragments. An attacker who can supply crafted ASN.1 input to an application that decodes it can exhaust CPU and cause a denial of service. Upgrade to pyasn1 0.6.5, the fixed version; until then, limit the size of untrusted input before it is decoded.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9m75-vc3g-4x39)

## Sources

- [GitHub Advisory Database: GHSA-9m75-vc3g-4x39](https://github.com/advisories/GHSA-9m75-vc3g-4x39)
- [OSV: GHSA-9m75-vc3g-4x39](https://osv.dev/vulnerability/GHSA-9m75-vc3g-4x39)
- <https://github.com/pyasn1/pyasn1/security/advisories/GHSA-9m75-vc3g-4x39>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-119195>
- <https://github.com/pyasn1/pyasn1/pull/132>
- <https://github.com/pyasn1/pyasn1/commit/4ce00797c594b59c1fd6b86d9ebc3ba87b7ec9f9>
- <https://github.com/pyasn1/pyasn1>
- <https://github.com/pyasn1/pyasn1/releases/tag/v0.6.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9m75-vc3g-4x39>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9m75-vc3g-4x39/>. Everything for agents: <https://agentprime.io/llms.txt>.
