# OpenLIT is an open source platform for AI engineering. Prior to version 1.37.1, several GitHub Actions workflows in OpenLIT's GitHub repository use the \`pull_request_target\` event while checking ou...

Advisory record · `GHSA-9jgv-x8cq-296q`

- **Identifiers:** `GHSA-9jgv-x8cq-296q` · `CVE-2026-27941` · `PYSEC-2026-2246`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-829](https://cwe.mitre.org/data/definitions/829.html)
- **Tags:** [CWE-829](https://agentprime.io/advisories/tag/cwe-829.md)
- **Published:** 26 Feb 2026
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Feb 2026, 02:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `openlit` (PyPI): affected `>=1.36.2, <1.37.1`; fixed in `1.37.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of openlit from 1.36.2 up to but not including 1.37.1 are affected, due to GitHub Actions workflows in the project's repository that run untrusted code from forked pull requests with base-repository privileges. An attacker who can open a pull request from a fork could run code with a write-privileged token and access to sensitive repository secrets, such as API keys and a Google Cloud service account key. Upgrade openlit to version 1.37.1 or later.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0045, the 39th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:04 UTC: First seen by agentprime
- 31 Oct 2026, 15:04 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-2246)

## Sources

- [GitHub Advisory Database: GHSA-9jgv-x8cq-296q](https://github.com/advisories/GHSA-9jgv-x8cq-296q)
- [OSV: GHSA-9jgv-x8cq-296q](https://osv.dev/vulnerability/GHSA-9jgv-x8cq-296q)
- <https://github.com/openlit/openlit/commit/4a62039a1659d6cbb8913172693f587b5fc2546c>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9jgv-x8cq-296q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9jgv-x8cq-296q/>. Everything for agents: <https://agentprime.io/llms.txt>.
