# Yamcs has Unauthenticated Directory Traversal

Advisory record · `GHSA-9jg3-g3wh-w9pj`

- **Identifiers:** `GHSA-9jg3-g3wh-w9pj` · `CVE-2026-55552`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md)
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Aug 2026, 17:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.yamcs:yamcs-core` (Maven): affected `<5.12.0`; fixed in `5.12.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Yamcs (Maven package org.yamcs:yamcs-core) versions before 5.12.0 are vulnerable to unauthenticated directory traversal, which lets a remote attacker read any file on the underlying host's operating system, such as sensitive system files. No authentication is needed. Upgrade to yamcs-core 5.12.0 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.017, the 77th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9jg3-g3wh-w9pj)

## Sources

- [GitHub Advisory Database: GHSA-9jg3-g3wh-w9pj](https://github.com/advisories/GHSA-9jg3-g3wh-w9pj)
- [OSV: GHSA-9jg3-g3wh-w9pj](https://osv.dev/vulnerability/GHSA-9jg3-g3wh-w9pj)
- <https://github.com/yamcs/yamcs/security/advisories/GHSA-9jg3-g3wh-w9pj>
- <https://github.com/yamcs/yamcs/commit/c7dfd24e469ae1086c23e0fe04401cb1ce4260d4>
- <https://github.com/yamcs/yamcs/commit/f4bc588880c166849e983aa8f65b9c8107d06091>
- <https://github.com/yamcs/yamcs>
- <https://github.com/yamcs/yamcs/releases/tag/yamcs-5.11.13>
- <https://github.com/yamcs/yamcs/releases/tag/yamcs-5.12.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9jg3-g3wh-w9pj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9jg3-g3wh-w9pj/>. Everything for agents: <https://agentprime.io/llms.txt>.
