# OpenZeppelin Contracts's Cross chain utilities for Arbitrum L2 see EOA calls as cross chain calls

Advisory record · `GHSA-9j3m-g383-29qr`

- **Identifiers:** `GHSA-9j3m-g383-29qr` · `CVE-2022-35916`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-669](https://cwe.mitre.org/data/definitions/669.html)
- **Tags:** [CWE-669](https://agentprime.io/advisories/tag/cwe-669.md)
- **Published:** 14 Aug 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Aug 2022, 00:25 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@openzeppelin/contracts` (npm): affected `>=4.6.0, <4.7.2`; fixed in `4.7.2`
- `@openzeppelin/contracts-upgradeable` (npm): affected `>=4.6.0, <4.7.2`; fixed in `4.7.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0060, the 48th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 Aug 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-9j3m-g383-29qr](https://github.com/advisories/GHSA-9j3m-g383-29qr)
- [OSV: GHSA-9j3m-g383-29qr](https://osv.dev/vulnerability/GHSA-9j3m-g383-29qr)
- <https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-9j3m-g383-29qr>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-35916>
- <https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3578>
- <https://github.com/OpenZeppelin/openzeppelin-contracts>
- <https://github.com/OpenZeppelin/openzeppelin-contracts/releases/tag/v4.7.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9j3m-g383-29qr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9j3m-g383-29qr/>. Everything for agents: <https://agentprime.io/llms.txt>.
