# Puma's header normalization allows for client to clobber proxy set headers

Advisory record · `GHSA-9hf4-67fc-4vf4`

- **Identifiers:** `GHSA-9hf4-67fc-4vf4` · `CVE-2024-45614`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html) · [CWE-639](https://cwe.mitre.org/data/definitions/639.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 20 Sept 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Sept 2024, 14:40 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `puma` (RubyGems): affected `<5.6.9 || >=6.0.0, <6.4.3`; fixed in `5.6.9`, `6.4.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0064, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9hf4-67fc-4vf4)

## Sources

- [GitHub Advisory Database: GHSA-9hf4-67fc-4vf4](https://github.com/advisories/GHSA-9hf4-67fc-4vf4)
- [OSV: GHSA-9hf4-67fc-4vf4](https://osv.dev/vulnerability/GHSA-9hf4-67fc-4vf4)
- <https://github.com/puma/puma/security/advisories/GHSA-9hf4-67fc-4vf4>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-45614>
- <https://github.com/puma/puma/commit/cac3fd18cf29ed43719ff5d52d9cfec215f0a043>
- <https://github.com/puma/puma/commit/f196b23be24712fb8fb16051cc124798cc84f70e>
- <https://github.com/puma/puma>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2024-45614.yml>
- <https://lists.debian.org/debian-lts-announce/2024/11/msg00004.html>
- <https://nginx.org/en/docs/http/ngx_http_core_module.html#underscores_in_headers>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9hf4-67fc-4vf4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9hf4-67fc-4vf4/>. Everything for agents: <https://agentprime.io/llms.txt>.
