# vLLM allows clients to crash the openai server with invalid regex

Advisory record · `GHSA-9hcf-v7m4-6m2j`

- **Identifiers:** `GHSA-9hcf-v7m4-6m2j` · `CVE-2025-48943` · `PYSEC-2025-55`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 28 May 2025
- **Updated:** 7 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 May 2025, 19:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.8.0, <0.9.0`; fixed in `0.9.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions 0.8.0 up to but not including 0.9.0 are affected. A client that sends an invalid regex while using structured output can crash the OpenAI-compatible server, causing a denial of service. The source gives few details about the required access level. Upgrade vLLM to version 0.9.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:40 UTC: First seen by agentprime
- 31 Oct 2026, 14:40 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9hcf-v7m4-6m2j)

## Sources

- [GitHub Advisory Database: GHSA-9hcf-v7m4-6m2j](https://github.com/advisories/GHSA-9hcf-v7m4-6m2j)
- [OSV: GHSA-9hcf-v7m4-6m2j](https://osv.dev/vulnerability/GHSA-9hcf-v7m4-6m2j)
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-9hcf-v7m4-6m2j>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-48943>
- <https://github.com/vllm-project/vllm/issues/17313>
- <https://github.com/vllm-project/vllm/pull/17623>
- <https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff>
- <https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2025-55.yaml>
- <https://github.com/vllm-project/vllm>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9hcf-v7m4-6m2j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9hcf-v7m4-6m2j/>. Everything for agents: <https://agentprime.io/llms.txt>.
