# Improper Control of Interaction Frequency in Apache syncope-core

Advisory record · `GHSA-9h9c-f287-c6vp`

- **Identifiers:** `GHSA-9h9c-f287-c6vp` · `CVE-2018-17184`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-799](https://cwe.mitre.org/data/definitions/799.html)
- **Tags:** [CWE-799](https://agentprime.io/advisories/tag/cwe-799.md)
- **Published:** 6 Nov 2018
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Nov 2018, 23:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.syncope:syncope-core` (Maven): affected `<2.0.11 || >=2.1.0, <2.1.2`; fixed in `2.0.11`, `2.1.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 68th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 6 Nov 2018. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-9h9c-f287-c6vp](https://github.com/advisories/GHSA-9h9c-f287-c6vp)
- [OSV: GHSA-9h9c-f287-c6vp](https://osv.dev/vulnerability/GHSA-9h9c-f287-c6vp)
- <https://nvd.nist.gov/vuln/detail/CVE-2018-17184>
- <https://github.com/advisories/GHSA-9h9c-f287-c6vp>
- <https://syncope.apache.org/security#CVE-2018-17184:_Stored_XSS>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9h9c-f287-c6vp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9h9c-f287-c6vp/>. Everything for agents: <https://agentprime.io/llms.txt>.
