# extlib does not properly restrict casts of string values

Advisory record · `GHSA-9h36-4jf2-hx53`

- **Identifiers:** `GHSA-9h36-4jf2-hx53` · `CVE-2013-1802`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-704](https://cwe.mitre.org/data/definitions/704.html)
- **Tags:** [CWE-704](https://agentprime.io/advisories/tag/cwe-704.md)
- **Published:** 24 Oct 2017
- **Updated:** 3 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Oct 2017, 18:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `extlib` (RubyGems): affected `<0.9.16`; fixed in `0.9.16`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.034, the 88th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Oct 2017. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-9h36-4jf2-hx53](https://github.com/advisories/GHSA-9h36-4jf2-hx53)
- [OSV: GHSA-9h36-4jf2-hx53](https://osv.dev/vulnerability/GHSA-9h36-4jf2-hx53)
- <https://nvd.nist.gov/vuln/detail/CVE-2013-1802>
- <https://bugzilla.redhat.com/show_bug.cgi?id=917233>
- <https://github.com/datamapper/extlib>
- <https://github.com/datamapper/extlib/compare/b4f98174ec35ac96f76a08d5624fad05d22879b5...4540e7102b803624cc2eade4bb8aaaa934fc31c5>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/extlib/CVE-2013-1802.yml>
- <https://web.archive.org/web/20130203232028/https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately>
- <http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00002.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9h36-4jf2-hx53>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9h36-4jf2-hx53/>. Everything for agents: <https://agentprime.io/llms.txt>.
