# Contao: Cross-site request forgery in custom backend actions

Advisory record · `GHSA-9ff2-p842-45wq`

- **Identifiers:** `GHSA-9ff2-p842-45wq` · `CVE-2026-107848` · `PKSA-6ymc-kdpm-qx87`
- **State:** Confirmed
- **Severity:** CVSS 3.5 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-352](https://cwe.mitre.org/data/definitions/352.html)
- **Tags:** [Cross-site request forgery (CSRF)](https://agentprime.io/advisories/tag/csrf.md)
- **Published:** 9 Oct 2026
- **Updated:** 9 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Oct 2026, 20:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `contao/core-bundle` (Packagist): affected `>=4.0.0, <5.3.50 || >=5.4.0-RC1, <5.7.12`; fixed in `5.3.50`, `5.7.12`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Contao contao/core-bundle versions from 4.0.0 before 5.3.50, and from 5.4.0-RC1 before 5.7.12, are affected. The source describes a cross-site request forgery weakness in back end actions dispatched through parameters other than \`act\`, because the token check only runs on POST and on GET only when \`act\` is present. An attacker who can get a logged-in back end user to load a crafted URL could trigger state-changing actions as that user, limited to the modules that user can access; the source says it found no such action granting privileges. Upgrade to contao/core-bundle 5.3.50 or 5.7.12.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.5 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0011, the 1st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:54 UTC: First seen by agentprime
- 31 Oct 2026, 13:54 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9ff2-p842-45wq)

## Sources

- [GitHub Advisory Database: GHSA-9ff2-p842-45wq](https://github.com/advisories/GHSA-9ff2-p842-45wq)
- [OSV: GHSA-9ff2-p842-45wq](https://osv.dev/vulnerability/GHSA-9ff2-p842-45wq)
- <https://github.com/contao/contao/security/advisories/GHSA-9ff2-p842-45wq>
- <https://github.com/contao/contao/commit/34dd27ee6739f10568d3d95d8784862255c925b4>
- <https://github.com/contao/contao>
- <https://github.com/contao/contao/releases/tag/5.7.12>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9ff2-p842-45wq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9ff2-p842-45wq/>. Everything for agents: <https://agentprime.io/llms.txt>.
