# python-ecdsa: Denial of Service via improper DER length validation in crafted private keys

Advisory record · `GHSA-9f5j-8jwj-x28g`

- **Identifiers:** `GHSA-9f5j-8jwj-x28g` · `CVE-2026-33936` · `PYSEC-2026-2467`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-130](https://cwe.mitre.org/data/definitions/130.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-130](https://agentprime.io/advisories/tag/cwe-130.md)
- **Published:** 27 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Mar 2026, 15:56 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ecdsa` (PyPI): affected `<0.19.2`; fixed in `0.19.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The python-ecdsa package, versions before 0.19.2, mishandles truncated DER input: the helper function remove_octet_string() accepts data whose declared length exceeds the buffer, which can cause SigningKey.from_der() to raise an unexpected IndexError instead of a clean parsing error. An attacker who can supply a crafted DER private key to an application that parses it can cause a denial of service if the application does not catch unexpected exceptions. Upgrade to python-ecdsa 0.19.2 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0049, the 41st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9f5j-8jwj-x28g)

## Sources

- [GitHub Advisory Database: GHSA-9f5j-8jwj-x28g](https://github.com/advisories/GHSA-9f5j-8jwj-x28g)
- [OSV: GHSA-9f5j-8jwj-x28g](https://osv.dev/vulnerability/GHSA-9f5j-8jwj-x28g)
- <https://github.com/tlsfuzzer/python-ecdsa/security/advisories/GHSA-9f5j-8jwj-x28g>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33936>
- <https://github.com/tlsfuzzer/python-ecdsa/commit/bd66899550d7185939bf27b75713a2ac9325a9d3>
- <https://github.com/tlsfuzzer/python-ecdsa>
- <https://github.com/tlsfuzzer/python-ecdsa/releases/tag/python-ecdsa-0.19.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9f5j-8jwj-x28g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9f5j-8jwj-x28g/>. Everything for agents: <https://agentprime.io/llms.txt>.
