# @nestjs/platform-fastify: Path-scoped middleware bypass via absolute-form request targets

Advisory record · `GHSA-9c5c-9qcx-q35q`

- **Identifiers:** `GHSA-9c5c-9qcx-q35q`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-288](https://cwe.mitre.org/data/definitions/288.html) · [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 30 Sept 2026
- **Updated:** 30 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Sept 2026, 14:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@nestjs/platform-fastify` (npm): affected `<11.2.4 || >=12.0.0, <12.0.2`; fixed in `11.2.4`, `12.0.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of @nestjs/platform-fastify below 11.2.4, and from 12.0.0 before 12.0.2, let a request with an absolute-form request target reach route handlers without running path-scoped middleware. A client that can send raw HTTP requests can thereby skip middleware such as authentication or authorization checks. Upgrade to 11.2.5 or 12.0.3, which the source recommends.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9c5c-9qcx-q35q)

## Sources

- [GitHub Advisory Database: GHSA-9c5c-9qcx-q35q](https://github.com/advisories/GHSA-9c5c-9qcx-q35q)
- [OSV: GHSA-9c5c-9qcx-q35q](https://osv.dev/vulnerability/GHSA-9c5c-9qcx-q35q)
- <https://github.com/fastify/middie/security/advisories/GHSA-hx87-8wv7-pjv8>
- <https://github.com/nestjs/nest/security/advisories/GHSA-9c5c-9qcx-q35q>
- <https://github.com/nestjs/nest/pull/17737>
- <https://github.com/nestjs/nest/commit/5226fe084cf64b357de436f154bc89f2d319b621>
- <https://github.com/nestjs/nest/commit/dda252090ecb65009d9ff366444303796fc44fd7>
- <https://github.com/nestjs/nest>
- <https://github.com/nestjs/nest/releases/tag/v11.2.4>
- <https://github.com/nestjs/nest/releases/tag/v12.0.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9c5c-9qcx-q35q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9c5c-9qcx-q35q/>. Everything for agents: <https://agentprime.io/llms.txt>.
