# phpMyFAQ has an incomplete fix for GHSA-xvp4-phqj-cjr3 — editUser() and updateUserRights() lack authorization guards

Advisory record · `GHSA-985r-q3qp-299h`

- **Identifiers:** `GHSA-985r-q3qp-299h` · `CVE-2026-56396` · `PKSA-bgmm-r5q1-dvfj` · `PKSA-nnfw-464q-679b`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-832](https://cwe.mitre.org/data/definitions/832.html) · [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-832](https://agentprime.io/advisories/tag/cwe-832.md)
- **Published:** 26 Jun 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Jun 2026, 21:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `thorsten/phpmyfaq` (Packagist): affected `<4.1.4`; fixed in `4.1.4`
- `phpmyfaq/phpmyfaq` (Packagist): affected `<4.1.4`; fixed in `4.1.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-985r-q3qp-299h affects the Packagist packages thorsten/phpmyfaq and phpmyfaq/phpmyfaq before 4.1.4. The source says the 4.1.3 fix for GHSA-xvp4-phqj-cjr3 was incomplete, leaving the editUser() and updateUserRights() methods without authorization checks. An administrator holding only the edit_user right, but not SuperAdmin, could reportedly set the is_superadmin flag on accounts, including their own, or grant rights to other accounts. Upgrade to version 4.1.4, which is listed as the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0044, the 38th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:01 UTC: First seen by agentprime
- 31 Oct 2026, 14:01 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-985r-q3qp-299h)

## Sources

- [GitHub Advisory Database: GHSA-985r-q3qp-299h](https://github.com/advisories/GHSA-985r-q3qp-299h)
- [OSV: GHSA-985r-q3qp-299h](https://osv.dev/vulnerability/GHSA-985r-q3qp-299h)
- <https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-985r-q3qp-299h>
- <https://github.com/thorsten/phpMyFAQ>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-985r-q3qp-299h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-985r-q3qp-299h/>. Everything for agents: <https://agentprime.io/llms.txt>.
