# ViewComponent: around_render HTML-Safety Bypass

Advisory record · `GHSA-97jw-64cj-jc58`

- **Identifiers:** `GHSA-97jw-64cj-jc58` · `CVE-2026-54498`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Jul 2026, 22:51 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `view_component` (RubyGems): affected `>=4.0.0, <4.12.0`; fixed in `4.12.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0045, the 39th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 15 Jul 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-97jw-64cj-jc58](https://github.com/advisories/GHSA-97jw-64cj-jc58)
- [OSV: GHSA-97jw-64cj-jc58](https://osv.dev/vulnerability/GHSA-97jw-64cj-jc58)
- <https://github.com/ViewComponent/view_component/security/advisories/GHSA-97jw-64cj-jc58>
- <https://github.com/ViewComponent/view_component/commit/48e5fd2d602344c7d33019fbc5c8b087e315bb78>
- <https://github.com/ViewComponent/view_component>
- <https://github.com/ViewComponent/view_component/releases/tag/v4.12.0>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/view_component/CVE-2026-54498.yml>
- <https://www.cve.org/CVERecord/SearchResults?query=CVE-2026-54498>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-97jw-64cj-jc58>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-97jw-64cj-jc58/>. Everything for agents: <https://agentprime.io/llms.txt>.
