# phpMyAdmin unsafely handles temporary files

Advisory record · `GHSA-9645-6g72-2pv8`

- **Identifiers:** `GHSA-9645-6g72-2pv8` · `CVE-2008-7252` · `PKSA-vvtr-znb6-rqfm`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-377](https://cwe.mitre.org/data/definitions/377.html)
- **Tags:** [CWE-377](https://agentprime.io/advisories/tag/cwe-377.md)
- **Published:** 17 May 2022
- **Updated:** 9 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 May 2022, 05:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `phpmyadmin/phpmyadmin` (Packagist): affected `>=2.11.0, <2.11.10`; fixed in `2.11.10`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> phpMyAdmin versions from 2.11.0 before 2.11.10 are affected. The source says libraries/File.class.php uses predictable filenames for temporary files, but it gives no details on the impact or how an attacker would exploit it. Upgrade to phpMyAdmin 2.11.10 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.027, the 86th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:32 UTC: First seen by agentprime
- 31 Oct 2026, 14:32 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9645-6g72-2pv8)

## Sources

- [GitHub Advisory Database: GHSA-9645-6g72-2pv8](https://github.com/advisories/GHSA-9645-6g72-2pv8)
- [OSV: GHSA-9645-6g72-2pv8](https://osv.dev/vulnerability/GHSA-9645-6g72-2pv8)
- <https://nvd.nist.gov/vuln/detail/CVE-2008-7252>
- <https://github.com/phpmyadmin/composer>
- <https://web.archive.org/web/20100613071447/http://secunia.com/advisories/38211>
- <https://web.archive.org/web/20100613071509/http://secunia.com/advisories/39503>
- <https://web.archive.org/web/20110729050522/http://www.securityfocus.com/bid/37826>
- <http://lists.opensuse.org/opensuse-security-announce/2010-01/msg00007.html>
- <http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/QA_2_11/phpMyAdmin/libraries/File.class.php?r1=11528&r2=11527&pathrev=11528>
- <http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin?view=rev&revision=11528>
- <http://www.debian.org/security/2010/dsa-2034>
- <http://www.phpmyadmin.net/home_page/security/PMASA-2010-2.php>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9645-6g72-2pv8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9645-6g72-2pv8/>. Everything for agents: <https://agentprime.io/llms.txt>.
