# Incorrect path canonicalization during Archive Extraction Leading to Arbitrary File Write

Advisory record · `GHSA-94vh-gphv-8pm8`

- **Identifiers:** `GHSA-94vh-gphv-8pm8` · `CVE-2025-29787` · `RUSTSEC-2025-0168`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-61](https://cwe.mitre.org/data/definitions/61.html) · [CWE-180](https://cwe.mitre.org/data/definitions/180.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [CWE-61](https://agentprime.io/advisories/tag/cwe-61.md) · [CWE-180](https://agentprime.io/advisories/tag/cwe-180.md)
- **Published:** 16 Mar 2025
- **Updated:** 12 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Mar 2025, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `zip` (crates.io): affected `>=1.3.0, <2.3.0`; fixed in `2.3.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The zip crate, versions 1.3.0 up to but not including 2.3.0, can be made to write files outside the intended directory during archive extraction. An attacker who supplies a crafted archive can use a symbolic link entry that appears earlier in the archive to redirect a later file's path, because the final canonicalized path is not checked, letting them overwrite arbitrary files when the archive is extracted. Upgrade to zip 2.3.0 or later. The source gives few details beyond this.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:H/SI:H/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0059, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2025-0168)

## Sources

- [GitHub Advisory Database: GHSA-94vh-gphv-8pm8](https://github.com/advisories/GHSA-94vh-gphv-8pm8)
- [OSV: GHSA-94vh-gphv-8pm8](https://osv.dev/vulnerability/GHSA-94vh-gphv-8pm8)
- <https://crates.io/crates/zip>
- <https://rustsec.org/advisories/RUSTSEC-2025-0168.html>
- <https://github.com/zip-rs/zip2/commit/a2e062f37066c3b12860a32eb1cb44856cfb7afe>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-94vh-gphv-8pm8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-94vh-gphv-8pm8/>. Everything for agents: <https://agentprime.io/llms.txt>.
