# virtualenv: Downloaded seed wheels (pip/setuptools) are not integrity-checked before use

Advisory record · `GHSA-94p9-xgh2-xp45`

- **Identifiers:** `GHSA-94p9-xgh2-xp45` · `BIT-virtualenv-2026-102930` · `CVE-2026-102930` · `PYSEC-2026-4011`
- **State:** Confirmed
- **Severity:** CVSS 7.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-494](https://cwe.mitre.org/data/definitions/494.html)
- **Tags:** [CWE-494](https://agentprime.io/advisories/tag/cwe-494.md)
- **Published:** 30 Sept 2026
- **Updated:** 6 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Sept 2026, 23:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `virtualenv` (PyPI): affected `<21.7.12`; fixed in `21.7.12`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Virtualenv versions before 21.7.12 do not verify the integrity of pip and setuptools wheels downloaded over the network, for the periodic-update feature or the --download flag. An attacker who can substitute a wheel, through a compromised or stale index or by intercepting TLS, could get a different wheel seeded into newly created environments without any warning. Upgrade to virtualenv 21.7.12, which checks downloaded wheels against the digest PyPI reports for that release; the check is skipped when a custom index is configured, so that case is not covered.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0020, the 9th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-94p9-xgh2-xp45)

## Sources

- [GitHub Advisory Database: GHSA-94p9-xgh2-xp45](https://github.com/advisories/GHSA-94p9-xgh2-xp45)
- [OSV: GHSA-94p9-xgh2-xp45](https://osv.dev/vulnerability/GHSA-94p9-xgh2-xp45)
- <https://github.com/pypa/virtualenv/security/advisories/GHSA-94p9-xgh2-xp45>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-102930>
- <https://github.com/pypa/virtualenv/pull/3251>
- <https://github.com/pypa/virtualenv/commit/a01ed3e2f239d6ab1fce62c5c7664ccf268fff6d>
- <https://github.com/pypa/advisory-database/tree/main/vulns/virtualenv/PYSEC-2026-4011.yaml>
- <https://github.com/pypa/virtualenv>
- <https://github.com/pypa/virtualenv/releases/tag/21.7.12>
- <https://pypi.org/project/virtualenv>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-94p9-xgh2-xp45>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-94p9-xgh2-xp45/>. Everything for agents: <https://agentprime.io/llms.txt>.
