# phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

Advisory record · `GHSA-94g3-g5v7-q4jg`

- **Identifiers:** `GHSA-94g3-g5v7-q4jg` · `CVE-2026-32935` · `PKSA-km2b-zc3b-mjm3`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-208](https://cwe.mitre.org/data/definitions/208.html)
- **Tags:** [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md)
- **Published:** 19 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Mar 2026, 16:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `phpseclib/phpseclib` (Packagist): affected `>=3.0.0, <3.0.50 || >=2.0.0, <2.0.52 || >=0.1.1, <1.0.27`; fixed in `3.0.50`, `2.0.52`, `1.0.27`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of the phpseclib PHP package from 0.1.1 up to 1.0.27, from 2.0.0 up to 2.0.52, and from 3.0.0 up to 3.0.50 are affected. The source says that those using AES in CBC mode may be susceptible to a padding oracle timing attack, but it gives few other details about what an attacker needs or what they could gain. Upgrade to 1.0.27, 2.0.52, or 3.0.50, depending on the release line in use. As a workaround, the source suggests using AES in CTR, CFB, or OFB mode.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0040, the 34th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:02 UTC: First seen by agentprime
- 31 Oct 2026, 14:02 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-94g3-g5v7-q4jg)

## Sources

- [GitHub Advisory Database: GHSA-94g3-g5v7-q4jg](https://github.com/advisories/GHSA-94g3-g5v7-q4jg)
- [OSV: GHSA-94g3-g5v7-q4jg](https://osv.dev/vulnerability/GHSA-94g3-g5v7-q4jg)
- <https://github.com/phpseclib/phpseclib/security/advisories/GHSA-94g3-g5v7-q4jg>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-32935>
- <https://github.com/phpseclib/phpseclib/commit/ccc21aef71eb170e9bf819b167e67d1fd9e6e788>
- <https://github.com/phpseclib/phpseclib>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-94g3-g5v7-q4jg>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-94g3-g5v7-q4jg/>. Everything for agents: <https://agentprime.io/llms.txt>.
