# Strapi core vulnerable to sensitive data exposure via CORS misconfiguration

Advisory record · `GHSA-9329-mxxw-qwf8`

- **Identifiers:** `GHSA-9329-mxxw-qwf8` · `CVE-2025-53092`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-284](https://cwe.mitre.org/data/definitions/284.html) · [CWE-364](https://cwe.mitre.org/data/definitions/364.html) · [CWE-942](https://cwe.mitre.org/data/definitions/942.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-364](https://agentprime.io/advisories/tag/cwe-364.md) · [CWE-942](https://agentprime.io/advisories/tag/cwe-942.md)
- **Published:** 16 Oct 2025
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Oct 2025, 19:49 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@strapi/core` (npm): affected `<5.20.0`; fixed in `5.20.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 16 Oct 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-9329-mxxw-qwf8](https://github.com/advisories/GHSA-9329-mxxw-qwf8)
- [OSV: GHSA-9329-mxxw-qwf8](https://osv.dev/vulnerability/GHSA-9329-mxxw-qwf8)
- <https://github.com/strapi/strapi/security/advisories/GHSA-9329-mxxw-qwf8>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-53092>
- <https://github.com/strapi/strapi/commit/6e535cb756>
- <https://github.com/strapi/strapi>
- <https://github.com/strapi/strapi/releases/tag/v5.20.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9329-mxxw-qwf8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9329-mxxw-qwf8/>. Everything for agents: <https://agentprime.io/llms.txt>.
