# Ruby SAML allows remote Denial of Service (DoS) with compressed SAML responses

Advisory record · `GHSA-92rq-c8cf-prrq`

- **Identifiers:** `GHSA-92rq-c8cf-prrq` · `BIT-gitlab-2025-25293` · `CVE-2025-25293`
- **State:** Confirmed
- **Severity:** CVSS 7.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 12 Mar 2025
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Mar 2025, 20:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ruby-saml` (RubyGems): affected `<1.12.4 || >=1.13.0, <1.18.0`; fixed in `1.12.4`, `1.18.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.015, the 74th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 Mar 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-92rq-c8cf-prrq](https://github.com/advisories/GHSA-92rq-c8cf-prrq)
- [OSV: GHSA-92rq-c8cf-prrq](https://osv.dev/vulnerability/GHSA-92rq-c8cf-prrq)
- <https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-92rq-c8cf-prrq>
- <https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-hw46-3hmr-x9xv>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-25293>
- <https://github.com/SAML-Toolkits/ruby-saml/commit/acac9e9cc0b9a507882c614f25d41f8b47be349a>
- <https://github.com/SAML-Toolkits/ruby-saml/commit/e2da4c6dae7dc01a4d9cd221395140a67e2b3eb1>
- <https://about.gitlab.com/releases/2025/03/12/patch-release-gitlab-17-9-2-released>
- <https://github.blog/security/sign-in-as-anyone-bypassing-saml-sso-authentication-with-parser-differentials>
- <https://github.com/SAML-Toolkits/ruby-saml>
- <https://github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.12.4>
- <https://github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.18.0>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2025-25293.yml>
- <https://lists.debian.org/debian-lts-announce/2025/04/msg00011.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-92rq-c8cf-prrq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-92rq-c8cf-prrq/>. Everything for agents: <https://agentprime.io/llms.txt>.
