# Wagtail: Identification of documents by SHA1 hash

Advisory record · `GHSA-92hv-j533-69wc`

- **Identifiers:** `GHSA-92hv-j533-69wc`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-280](https://cwe.mitre.org/data/definitions/280.html)
- **Tags:** [CWE-280](https://agentprime.io/advisories/tag/cwe-280.md)
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Aug 2026, 18:45 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wagtail` (PyPI): affected `<7.0.9 || >=7.1, <7.3.4 || >=7.4, <7.4.3 || >=8.0rc1, <8.0rc2`; fixed in `7.0.9`, `7.3.4`, `7.4.3`, `8.0rc2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Wagtail versions before 7.0.9, 7.1 through before 7.3.4, 7.4 through before 7.4.3, and 8.0rc1 before 8.0rc2 are affected. An attacker can send specially crafted HTTP headers to the document serve endpoint to learn whether a document with a given ID matches a known SHA1 hash, regardless of permissions, but cannot see document contents or other metadata. Upgrade to Wagtail 7.0.9, 7.3.4, 7.4.3, 8.0rc2, or later. Sites that cannot upgrade can strip If-Match and If-None-Match headers from anonymous requests to /documents/ at the reverse proxy.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:39 UTC: First seen by agentprime
- 31 Oct 2026, 14:39 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-92hv-j533-69wc)

## Sources

- [GitHub Advisory Database: GHSA-92hv-j533-69wc](https://github.com/advisories/GHSA-92hv-j533-69wc)
- [OSV: GHSA-92hv-j533-69wc](https://osv.dev/vulnerability/GHSA-92hv-j533-69wc)
- <https://github.com/wagtail/wagtail/security/advisories/GHSA-92hv-j533-69wc>
- <https://github.com/wagtail/wagtail>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-92hv-j533-69wc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-92hv-j533-69wc/>. Everything for agents: <https://agentprime.io/llms.txt>.
