# Grav: Decompression Bomb via ZipArchiver - Missing Extraction Limits

Advisory record · `GHSA-928x-9mpw-8h56`

- **Identifiers:** `GHSA-928x-9mpw-8h56` · `CVE-2026-61455` · `CVE-2026-61690` · `PKSA-2vrn-cxz9-yg23`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-409](https://cwe.mitre.org/data/definitions/409.html)
- **Tags:** [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 2 Sept 2026
- **Updated:** 2 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Sept 2026, 21:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `getgrav/grav` (Packagist): affected `<2.0.1`; fixed in `2.0.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> This advisory covers Grav versions before 2.0.1, where the ZipArchiver::extract() method does not limit uncompressed size, file count, or nesting depth when extracting ZIP archives. An attacker who can get a crafted ZIP archive extracted through this path, such as a third-party plugin or custom code that handles user-supplied archives, could fill the server's disk with a small archive that expands to a very large size, causing denial of service. The fix is to upgrade to Grav 2.0.1 or later, which is listed as the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 45th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:06 UTC: First seen by agentprime
- 31 Oct 2026, 14:06 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-928x-9mpw-8h56)

## Sources

- [GitHub Advisory Database: GHSA-928x-9mpw-8h56](https://github.com/advisories/GHSA-928x-9mpw-8h56)
- [OSV: GHSA-928x-9mpw-8h56](https://osv.dev/vulnerability/GHSA-928x-9mpw-8h56)
- <https://github.com/getgrav/grav/security/advisories/GHSA-928x-9mpw-8h56>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-61690>
- <https://github.com/getgrav/grav/commit/1c1003cfcab5344203d6fde1aaa1f9a4ee3413ff>
- <https://github.com/getgrav/grav>
- <https://github.com/getgrav/grav/releases/tag/2.0.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-928x-9mpw-8h56>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-928x-9mpw-8h56/>. Everything for agents: <https://agentprime.io/llms.txt>.
