# Yamcs has DOM XSS in Extension Routing

Advisory record · `GHSA-9272-wg2r-7xmx`

- **Identifiers:** `GHSA-9272-wg2r-7xmx` · `CVE-2026-55566`
- **State:** Confirmed
- **Severity:** CVSS 4.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Aug 2026, 17:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.yamcs:yamcs-core` (Maven): affected `>=5.13.0, <5.13.2 || <5.12.8`; fixed in `5.13.2`, `5.12.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Yamcs (org.yamcs:yamcs-core) versions 5.13.0 up to but not including 5.13.2, and versions below 5.12.8, are affected by a DOM-based cross-site scripting flaw in the /ext URL endpoint. An unauthenticated attacker can craft a URL that runs arbitrary JavaScript in a user's browser when opened, such as through a phishing email. Upgrade to version 5.13.2 or 5.12.8. The source gives no workaround for users who cannot upgrade.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0038, the 32nd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-9272-wg2r-7xmx)

## Sources

- [GitHub Advisory Database: GHSA-9272-wg2r-7xmx](https://github.com/advisories/GHSA-9272-wg2r-7xmx)
- [OSV: GHSA-9272-wg2r-7xmx](https://osv.dev/vulnerability/GHSA-9272-wg2r-7xmx)
- <https://github.com/yamcs/yamcs/security/advisories/GHSA-9272-wg2r-7xmx>
- <https://github.com/yamcs/yamcs/commit/8e18e279d8ce761c21f4f67bbd06a1bff804d297>
- <https://github.com/yamcs/yamcs/commit/ecf34a4e2ccbe085e6ceff0253595b24d5ecb4aa>
- <https://github.com/yamcs/yamcs>
- <https://github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8>
- <https://github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-9272-wg2r-7xmx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-9272-wg2r-7xmx/>. Everything for agents: <https://agentprime.io/llms.txt>.
