# undici vulnerable to downstream response desynchronization via retry interceptor

Advisory record · `GHSA-8xcm-r25x-g524`

- **Identifiers:** `GHSA-8xcm-r25x-g524` · `CVE-2026-16728`
- **State:** Confirmed
- **Severity:** CVSS 4.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 3 Aug 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Aug 2026, 19:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `undici` (npm): affected `<6.28.0 || >=7.0.0, <7.29.0 || >=8.0.0, <8.9.0`; fixed in `6.28.0`, `7.29.0`, `8.9.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 3 Aug 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-8xcm-r25x-g524](https://github.com/advisories/GHSA-8xcm-r25x-g524)
- [OSV: GHSA-8xcm-r25x-g524](https://osv.dev/vulnerability/GHSA-8xcm-r25x-g524)
- <https://github.com/nodejs/undici/security/advisories/GHSA-8xcm-r25x-g524>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-16728>
- <https://github.com/nodejs/undici/commit/1b5a5312c3a7d7a30c31bf0d000b39a8a2531e1c>
- <https://github.com/nodejs/undici/commit/2b3f749336d356bbbc50192f87f6cf7bc714721a>
- <https://github.com/nodejs/undici/commit/4a9dafb16ff43880cf590e6d9c2aeee25fbff6d7>
- <https://github.com/nodejs/undici/commit/4fd5a0c61e627f928b7003adc4ffe1e55ec63420>
- <https://github.com/nodejs/undici/commit/cba3a52ac2e7abcc4e656d82af8579ea82c2bb9e>
- <https://github.com/nodejs/undici/commit/e11a68ed4ff345c79402476f7a00d473443e318d>
- <https://hackerone.com/reports/3828685>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/nodejs/undici>
- <https://github.com/nodejs/undici/releases/tag/v6.28.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8xcm-r25x-g524>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8xcm-r25x-g524/>. Everything for agents: <https://agentprime.io/llms.txt>.
