# Authentication Bypass by Primary Weakness in github.com/kongchuanhujiao/server

Advisory record · `GHSA-8wrg-m8vm-5fvj`

- **Identifiers:** `GHSA-8wrg-m8vm-5fvj` · `CVE-2021-21403`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html) · [CWE-305](https://cwe.mitre.org/data/definitions/305.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-305](https://agentprime.io/advisories/tag/cwe-305.md)
- **Published:** 15 Feb 2022
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Feb 2022, 01:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/kongchuanhujiao/server` (Go): affected `<1.3.21`; fixed in `1.3.21`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The Go module github.com/kongchuanhujiao/server is vulnerable in versions before 1.3.21 to an authentication bypass (CWE-305, Authentication Bypass by Primary Weakness). The source gives few details on how the bypass works or what access an attacker needs, but it states that all users are affected. Upgrade to version 1.3.21.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.014, the 71st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:05 UTC: First seen by agentprime
- 31 Oct 2026, 15:05 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8wrg-m8vm-5fvj)

## Sources

- [GitHub Advisory Database: GHSA-8wrg-m8vm-5fvj](https://github.com/advisories/GHSA-8wrg-m8vm-5fvj)
- [OSV: GHSA-8wrg-m8vm-5fvj](https://osv.dev/vulnerability/GHSA-8wrg-m8vm-5fvj)
- <https://github.com/kongchuanhujiao/server/security/advisories/GHSA-8wrg-m8vm-5fvj>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-21403>
- <https://github.com/kongchuanhujiao/server/commit/9a125624f219e496bdf4b07b404816d5a309bdc1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8wrg-m8vm-5fvj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8wrg-m8vm-5fvj/>. Everything for agents: <https://agentprime.io/llms.txt>.
