# Dulwich: Symlink write-through in checkout(paths=\[\]) via raw os.open bypasses all symlink protections

Advisory record · `GHSA-8w8g-wq8h-fq33`

- **Identifiers:** `GHSA-8w8g-wq8h-fq33` · `CVE-2026-114096`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-59](https://cwe.mitre.org/data/definitions/59.html) · [CWE-61](https://cwe.mitre.org/data/definitions/61.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [CWE-61](https://agentprime.io/advisories/tag/cwe-61.md)
- **Published:** 2 Oct 2026
- **Updated:** 21 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Oct 2026, 18:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `dulwich` (PyPI): affected `>=0.24.0, <1.2.8`; fixed in `1.2.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Dulwich versions 0.24.0 up to but not including 1.2.8 are vulnerable. When porcelain.checkout is called with a paths list, files are written with a raw os.open call that follows symlinks, so a malicious repository containing a symlink can cause writes to arbitrary locations, such as git hook files. An attacker needs a victim to clone the crafted repository and run that checkout; the write can then lead to code execution on a later git operation. Upgrade to Dulwich 1.2.8, which contains the fix.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0015, the 4th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8w8g-wq8h-fq33)

## Sources

- [GitHub Advisory Database: GHSA-8w8g-wq8h-fq33](https://github.com/advisories/GHSA-8w8g-wq8h-fq33)
- [OSV: GHSA-8w8g-wq8h-fq33](https://osv.dev/vulnerability/GHSA-8w8g-wq8h-fq33)
- <https://github.com/jelmer/dulwich/security/advisories/GHSA-8w8g-wq8h-fq33>
- <https://github.com/jelmer/dulwich/commit/9389fcb5cb9113adfc7f207d8be86a56904db3e8>
- <https://github.com/jelmer/dulwich>
- <https://github.com/jelmer/dulwich/releases/tag/dulwich-1.2.8>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8w8g-wq8h-fq33>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8w8g-wq8h-fq33/>. Everything for agents: <https://agentprime.io/llms.txt>.
