# ArcadeDB: IMPORT DATABASE allows SSRF and arbitrary local file read by authenticated users

Advisory record · `GHSA-8w86-m9h8-hvqg`

- **Identifiers:** `GHSA-8w86-m9h8-hvqg` · `CVE-2026-54077`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-776](https://cwe.mitre.org/data/definitions/776.html) · [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md)
- **Published:** 16 Jul 2026
- **Updated:** 16 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Jul 2026, 20:05 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `com.arcadedb:arcadedb-engine` (Maven): affected `<26.6.1`; fixed in `26.6.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> ArcadeDB (com.arcadedb:arcadedb-engine) versions before 26.6.1 let any authenticated user with SQL command access run IMPORT DATABASE, which lacked an administrative check and did not validate its source URL. An attacker with such an account can make the server send requests to internal or cloud metadata addresses and read local files the server process can access, with the results returned as database records. Upgrade to 26.6.1 or later; the fix requires administrative permission for the import and blocks local-network HTTP sources and restricts file paths by default.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0045, the 39th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8w86-m9h8-hvqg)

## Sources

- [GitHub Advisory Database: GHSA-8w86-m9h8-hvqg](https://github.com/advisories/GHSA-8w86-m9h8-hvqg)
- [OSV: GHSA-8w86-m9h8-hvqg](https://osv.dev/vulnerability/GHSA-8w86-m9h8-hvqg)
- <https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-8w86-m9h8-hvqg>
- <https://github.com/ArcadeData/arcadedb>
- <https://github.com/ArcadeData/arcadedb/releases/tag/26.6.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8w86-m9h8-hvqg>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8w86-m9h8-hvqg/>. Everything for agents: <https://agentprime.io/llms.txt>.
