# Crass: Non-ASCII characters cause superlinear CPU consumption

Advisory record · `GHSA-8vfg-2r28-hvhj`

- **Identifiers:** `GHSA-8vfg-2r28-hvhj` · `CVE-2026-61848`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Oct 2026, 16:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `crass` (RubyGems): affected `<1.0.7`; fixed in `1.0.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The crass Ruby gem versions before 1.0.7 have a parsing inefficiency: when input contains non-ASCII characters, Crass tracks multi-byte character positions in a way that makes parsing time grow superlinearly. An attacker who can supply input to be parsed could drive excessive CPU use and cause a denial of service. Upgrade to crass 1.0.7 or later. The source gives few details on workarounds beyond avoiding non-ASCII input.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0049, the 41st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:21 UTC: First seen by agentprime
- 31 Oct 2026, 14:21 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8vfg-2r28-hvhj)

## Sources

- [GitHub Advisory Database: GHSA-8vfg-2r28-hvhj](https://github.com/advisories/GHSA-8vfg-2r28-hvhj)
- [OSV: GHSA-8vfg-2r28-hvhj](https://osv.dev/vulnerability/GHSA-8vfg-2r28-hvhj)
- <https://github.com/rgrove/crass/security/advisories/GHSA-8vfg-2r28-hvhj>
- <https://github.com/rgrove/crass>
- <https://github.com/rgrove/crass/releases/tag/v1.0.7>
- <http://github.com/rgrove/crass/commit/da29664648bf80a97a6439e030a4814291c9afa5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8vfg-2r28-hvhj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8vfg-2r28-hvhj/>. Everything for agents: <https://agentprime.io/llms.txt>.
